Variable Fonts Bugs in the Arabic Script

While generating bi-script Latin and Arabic fonts, I am facing two problems in the Arabic:

1. In Web Browsers:
The Arabic RTL kerning is applied as LTR kerning. This is resulting in baseline disconnections on the RSB of the letters with kerning on LSB, and the kerning on the LSB is not applied and letters overlapping with the proceeding glyph.

2. In Adobe Applications:
The Arabic letters only show in isolated positions resulting in disconnected Arabic.

Any suggestions or solution for these two bugs at the moment?


1 Like

Which build version of the app are you using, and where are you testing?

I am on the latest stable version of Glyphs V2.6.123.

I am testing on browsers using:
Font Gauntlet
Wakamai Findue
Axis Praxis
Font Drop

And your script :
Variable Font Test HTML

And Abobe Apps :
Adobe CC 2018

Last time I checked, Illustrator was ignoring most (!) OpenType features when there is a gvar table. That makes it impossible to build Arabic fonts for Illustrator.

So at present moment, Variable fonts with Arabic character set don’t work on Adobe Apps?
Any plans from Adobe to support Arabic Opentype Features in gvar tables soon?

What about the RTL kerning problem in browsers?
How to solve that?

What version of Glyphs do you have?

Glyphs V2.6.123

Please try the latest cutting edge version. The RTL metrics should be fixed.

1- For the RTL kerning it’s more practical once you add a feature as below, additional to the manual setting :

pos reh-ar hamza-ar -144;
  • Where the second letter can be a class that holds all the cases.

2- For the isolated issue, Once your fonts have the features correctly + the Unicode and you tested well in Glyphs that mean the problem is with Adobe apps,
And till now Adobe Apps does not support Arabic Variable fonts yet, although you can type Arabic letters manually as below example using some script for testing usage.

ﻛـــﻞ ﻋــــﺎم وأﻧـﺘــــــﻢ ﺑﺨـــــــﻴﺮ 
ﻛ ـــﻞ ﻋــــﺎم وأﻧـ ﺘ ــــــ ﻢ ﺑ ﺨ ـــــــ ﻴ ﺮ 


About RTL kerning problem
Perhaps you have chosen the kerning direction in reverse.

You can select multiple glyphs and create the kerning group in in the bottom left of the window.

Hello Georg,

I was trying t stick to stable versions in order to avoid unwanted bugs.

I just updated to the latest Version 2.6.2 (1243) and tried to generate the fonts but Glyphs is “NOT RESPONDING” and quieting.

Any stable version coming soon or a previous one that supports the RTL Arabic feature in variable fonts?

Can you send us the file? You know, support at this domain.

There is really something wrong in the latest cutting edge version of Glyphs.

In the previous version, all the Arabic glyphs created from components are properly auto alignment with anchors.
When I open the file in the latest version, A pop-up menu comes up and says that there are 282 glyphs in Red and they need to be fixed. If I let it fix them, the glyphs are broken and spacing is damaged. If I don’t allow it, all the auto alignment is broken in all the 282 glyphs.

Also, the Arabic character set preview is broken

This is not what the dialog says. It is about unspecified alignment of components. Please read carefully and make a decision about auto alignment. Probably you want to keep their position and not align them in this case.

There is a problem with calculating the script for some glyphs. I’ll have a look.

All the listed glyphs in red have a specified alignment of components. By “fixed” I meant that it seems it is seeing that the glyphs have Automatic Alignment off or incorrect, while there are in the previous glyphs version. This is only affecting the Arabic glyphs and not the Latin ones.

Just updated to Version 2.6.2 (1244).
The Arabic script calculation of script is fixed. The order of the Arabic glyphs is displaying well now and I am not getting anymore the pop-up menu when opening the files telling me that the automatic alignment is off.

There is still the problem of generating variable fonts though.
Try to generate from the latest version to check if the RTL kerning problem is solved, but Glyphs is Not responding then quieting every time I am trying.

1 Like

Can you send me the .glyphs file?