Various bug reports

Using version 1.3.26 (530) on OSX 10.8.5.

  1. When copying, pasting, or even just selecting lengthy text in edit view crashes the app.

  2. Correct Path Direction now erases segments, not always but rather often.
    (Update: it’s actually the copying of outline that causes distortion)

  3. When the 2 happens, the segment become tricky to edit. I can’t cut the segment with scissors tool, can’t add node, and when I choose Open Corner, the result doesn’t respect the original angle.

  4. The background image goes off while zooming. It hasn’t been fixed for quite a while.

  5. In rectangle and circle tool, hitting tab on a numerical drawing dialogue doesn’t cycle between vertical and horizontal values. And values sometimes disappear (although they seem present internally).

  6. In the Fit Curve of the transformation Palette, hitting tab in the minimal value field takes you to the 6th button, not to the maximum.

  7. As reported elsewhere, hitting Cmd+A twice doesn’t select anchors and components anymore. It was a cool feature, and I want it back.

  8. This is a feature request. I love that you can do the measurement and convert it into a guideline by hitting g, but I really want when I do that is the measurement guideline. Could you automatically activate the measurement option when you add a guideline that way?

2&3: can you send us a file where this happens?

7: This is a bug in 1.3.26. Fixed in the upcoming version.

1: I cannot reproduce this. Does this persist after a system restart?

1 It is persistent, from 1.3.24. I’ll show you at the ATypI if you’re coming.

2&3 Will do later.

7 Thanks!

1: Can you send me a screenshot of the edit view with all the text? And which features do you have enabled?

I think problem 2&3 are related with with undo and the background problem. I fixed both.

4: Fixed it. This also fixed the grid offset problem while zooming.

7: Fixed it.

8: You are right. Changed that.

  1. No feature enabled. I think it’s easier to show you somehow. Maybe at ATypI?

I agree that 2&3 has something to do with background. I actually had another issue that Glyphs seems to get confused with foreground and background.

Thanks for the update!

I also found a bug in the new character view. I have some pretty large letters for a special font that are 1600 pts wide, and the zoom function doesn’t allow me to get to any sections of my letters to the right of x:1150 when zoomed in at anything above 1500pt. When panning, it just pretends the page ends at x:1150.

Any ideas?

Edit: I use glyphs mini!

Just add a space or any other character.

Good thinking… Thanks. :slight_smile:

Never mind actually, there is no bug. The width was not adjusted on some letters after copying in new paths from Illustrator. Now I did it manually and it works perfectly. My apologies!

Thanks for the new beta. Many of the reports above were fixed! I’m reporting new ones.

  1. When I switch between different masters, the screen doesn’t stick to the glyph I am working on, and I have to zoom out to find where the it went. The app seems to not pay attention to it anymore.

  2. Moving and rotating guidelines cannot be undone but Glyphs is executing undo step, so the app at least knows that I have done something to the guideline. Please make it undoable. I think this is not a new bug but hasn’t been fixed yet.

Global guidelines can’t have undo. The undo is glyph based but the global guidelines do not belong to any glyph. So if I would put the undo in the currently active glyph, then you go to another glyph, change the guideline again then go back to the first and hit undo it will go crazy.
fixed it. Thanks

Just uploaded a new update that should fix this issues.

If I may add a little to the pool, I am suffering these bugs:

  1. Some OpenType features are not generated automatically based on glyph names

I worked quite a lot on fixing number 2. I hope I have succeeded.

Can you post a screenshot of the scrolling problems?

What do you mean by the dlig feature is not generated. All ligature glyphs are put there automatically. So if you have a glyph T_h it will end up in the dlig feature. Only a few standard ligatures (like f_i) will go to the liga feature. If you like to put a special ligature into the liga feature add a .liga suffix. That means that there is no need to a dlig suffix. Or do you try to add single substitutions to the feature?

Number 2 looks alright so far, thanks!

Here’s the scrolling thing:

About dlig: of course, you are right. Dlig suffix is probably not needed. For I don’t know what’s sake I just tried to add it to some glyphs and was confused that it doesn’t work the same way as .liga suffix. Maybe, just maybe, it would be helpful for filtering in font view.

Thought I’d add to this a bug I’ve encountered as well, I’m on version 1.3.26 (534).

When the Fit Curve panel is expanded to full view and collapsed back to single-line view multiple times, the content of the panel shifts and eventually disappears. I’ve found that restarting Glyphs restores the panel, but is unusable before a restart.


Global guides:
I just wanted to add a filter for a global guide which I only want to see in 4 specific glyphs. I added one filter, using “Name” is “[myGlyphName2]”. So far so good. I expected, though, that I can add more glyph names like this. Apparently this doesn’t work, it seems to check now for glyph names if they are exactly both my desired name. Since no glyph obviously has a name “[myGlyphname1myGlyphname2]”, the guide just disappeared. I guess they are now somewhere in the file, not accessible via UI. I might remove it in a text editor. Anyhow, It would be awesome to provide a list of glyphNames that you want to see the guide in. It’s 2019 and I still heavily refuse to use guides because I hate them to clutter my sight where I don’t need them :slight_smile:

Sorry for posting it in this thread. Searched for an appropriate global guides thread, but didn’t find anything suitable.

1 Like

Hold the Opt and press the plus button to get the “Any” row.

1 Like