Variable font naming for italic face (conflict with regular)

I have 2 variable font glyphs files for upright (regular) and italic that have the same family name, style linking and 9 export instances for each face. I’ve read the naming, MM docs and forum posts related to naming with the VF italic face (but may have missed something). At issue is the italic face produces a ‘regular’ instance name that conflicts with the already installed ‘upright’ face for regular weight. Everything else seems to work okay. From what I can glean, it appears a solution for this may be in the 3.2 version, is that accurate? Or, is there something else I need to do for custom parameters and naming? I’m unable to purchase OTMaster at this time to manually make the changes to the name variables. I used FontTableViewer, for the italic VF font, to verify that name IDs 2 Mac Roman, 2 Win Unicode, 17 Win Unicode, etc show ‘regular’. I’m assuming I need them to be ‘italic’ for this to work, but may be wrong.

Do you have a “Variable Font Setting” in Font Info > Exports. Add one and give it a style name “Italic”.

I was unable to find anything like “Variable Font Setting” parameter in either General or Custom Parameters of Font Info>Exports. I attached screenshots of Custom Parameters. I’m at V 3.1.1 (3144). Does that parameter come with V3.2?
2022-11-10_21-52-16
2022-11-10_21-51-46
2022-11-10_21-50-54
2022-11-10_21-50-37
2022-11-10_21-50-17

Variable Font Setting, is a variable instance, to add it, click on the + button.
Capture d’écran 2022-11-11 à 09.02.02

Thanks! I sometimes lack a natural grasp for the obvious. Now things like the ‘fileName’ parameter make more sense.
I have additional followup questions

  1. Do I also need to add a Variable Font Setting instance to my Regular VF (set to regular)?
  2. I’m using the same family name for both regular and italic, with different fileName for export. When I import using Font Book I get the ‘already installed’ dialog. I can select ‘keep both’, but is there another parameter I need to set so the user doesn’t have to make this choice?
  3. When I examine the faces in Font Book, I see Italic listed twice (they have slightly different weights). in Exports I have an Italic instance, style linking enabled and Axes coord Italic=1. What do I need to do differently?
  4. Even though FontBook shows the separate regular/italic instances, in Word/Pages/Mellel I only see the italic faces. Do I need to implement ‘Has WWS Names’ (or other params) in the Variable Font Settings custom parameter so I can install using a single family name? Or, do I use the WWS Family/Subfamily parms for each instance (per the naming doc.)?
    2022-11-11_09-32-03
    2022-11-11_09-33-43

I had similar problems naming my Variable Upright+Italic fonts. Take a look at this post you can see (screenshots) the way I set my Variable Font Setting – it works:

In the end i just changed Name: Default to Name: Regular, for the regular style. If you have different names under fileName there should be no conflict in Font Book, maybe you need to clear your font cache.

Thanks for the feedback. I had previously read your post, and tried the post solutions (which went along with this thread feedback), with no success. There’s something I’m missing. Here are screenshots of the upright and italic settings. I set up a package for font cache clearing with shortcuts since I run it often.




Your Localized Family Names should be different from your Family Name in the first tab because that is for the static fonts. Just put Dupuis VF in both Regular and Italic for the Localized Family Name.

P.S. You did not post the Family Name field in your screenshot, I’m just assuming it’s Dupuis.

I previously tried a different Localized Family Name attribute with no change to the result.



When I install the upright version I get this in FontBook
2022-11-13_09-59-04
When I then install italic I get this:
2022-11-13_09-59-28
I choose ‘keep both’ and see this (the only oddity is Italic is listed twice, but that may be related to variable origin.)
2022-11-13_09-59-55
However, in Word I only see the upright style names, but they have the italic faces:
2022-11-13_10-00-58
I had my clear font caches in a shell script that I executed from a package. I ran each command individually and found an OS error (don’t know yet if this is important. There used to be a fontprotection system some OSs ago, but it doesn’t seem to be applicable with Ventura):

% sudo atsutil databases -remove

Removing: /var/folders/zz/zyxvpxvq6csfxvn_n00000c4000031/C/com.apple.FontRegistry
2022-11-13 09:52:01.358 atsutil[1300:13839] Error: Error Domain=NSCocoaErrorDomain Code=4 ““com.apple.FontRegistry” couldn’t be removed.” UserInfo={NSUserStringVariant=(
Remove
), NSFilePath=/var/folders/zz/zyxvpxvq6csfxvn_n00000c4000031/C/com.apple.FontRegistry, NSUnderlyingError=0x600000e38630 {Error Domain=NSPOSIXErrorDomain Code=2 “No such file or directory”}}
Removing: /var/folders/8h/57r6_fq51498g04__5wr_c9r0000gn/C/com.apple.FontRegistry

I searched around and didn’t find any hits on errors with atsutil, maybe something has changed with Ventura perms. I then tried to use the Onyx ‘Fonts cache’ option. It ran with no errors, but there is no change to the Word/Pages behavior.
With Pages I see that only the Italic styles appear, but the names are correct.
2022-11-13_10-31-00
I’m thinking it has to be a naming issue. I’ve been through the naming, variable and masters docs (and forum posts) a number of times and haven’t found a solution yet. But, there are a number of exceptions stated that I don’t know if they apply to my situation.

Can you post the entire screenshot of the first tab in Font Info > Font?

Will try again. Had errors earlier with big .jpeg.


You need to name the variable font setting the same as the variable font origin (first master of the font if not specified otherwise).

Or try to remove Variable Font Origin for now.

I renamed the variable font setting name to be the same as the VF origin (Thin for upright and Italic thin for Italic). The behaviors did not change. On Font Book install I still see the keep/skip/replace dialog. A keep both shows both upright/italic in the FB list, but Word/Pages only shows the Italic.

I removed the VF origin and reset the VF Name to Regular for upright and Italic for Italic. The behaviors did not change. On Font Book install I still see the keep/skip/replace dialog. A keep both shows both upright/italic in the FB list, but Word/Pages only shows the Italic (for Word it is the upright name with the Italic face).
My workflow is delete the family in Font Book, export the faces, use Onyx to clear the font cache, restart, install the latest family exports.

Do you have the same static font family also installed? If you do, try to remove it, see what happens.

Wait, why do you have the Ital axis in italic? That is the problem. Remove that and try again

I don’t have static versions installed, just this variable. I removed the italic axes with no change in behaviors. I also read, somewhere in a post, that I needed to use the font origin to prevent the Italic face from appearing twice in the style list. That is why it was enabled.

OK, looking at these screenshots I think you set the Variable Font Setting correctly. The problem still feels like a font cache problem, but if you cleared that and reset the computer it must be the naming. How did you name your instances, can you give us the screenshot? Especially the Italics.

Here are the instances for upright and regular:



I based the style linking on this (but I may not be implementing it correctly):

For instance:

I also tried this script for cache cleaning:

try
    do shell script "sudo atsutil databases -remove" with administrator privileges
on error errMsg number errNum
    display dialog "Font cache error " & errNum & ": " & errMsg
end try
do shell script "atsutil server -shutdown"
do shell script "atsutil server -ping"
set buttonAnswer to text of button returned of (display dialog "It is strongly recommended that you restart your Mac, or at least log out and back in again." with title "Font caches cleaned" with icon caution buttons {"Restart", "Log out", "Later"} default button 3)
if buttonAnswer is "Log out" then
    tell application "System Events" to log out
else if buttonAnswer is "Restart" then
    tell application "System Events" to restart
end if

When I ran it the summary restart dialog appeared, a but no error was shown. However, when I run atsutil from the command prompt I see this:

sudo atsutil databases -remove
Password:
Removing: /var/folders/zz/zyxvpxvq6csfxvn_n00000c4000031/C/com.apple.FontRegistry
2022-11-14 09:31:45.579 atsutil[1383:14563] Error: Error Domain=NSCocoaErrorDomain Code=4 ““com.apple.FontRegistry” couldn’t be removed.” UserInfo={NSUserStringVariant=(
Remove
), NSFilePath=/var/folders/zz/zyxvpxvq6csfxvn_n00000c4000031/C/com.apple.FontRegistry, NSUnderlyingError=0x600001c30630 {Error Domain=NSPOSIXErrorDomain Code=2 “No such file or directory”}}
Removing: /var/folders/8h/57r6_fq51498g04__5wr_c9r0000gn/C/com.apple.FontRegistry

I also tried a safe boot several times with no change to behavior. The safe boot process on Apple Silicon is a little more involved than intel. I wondering if something has changed in Ventura for font cache cleaning?